Results 1 to 15 of 15

Thread: No bubbles in my coral life skimmer.

  1. #1
    Public Relations Liasion

    static reef's Avatar

    Join Date
    Nov 2012
    Location
    colorado
    Posts
    3,793
    Post Thanks / Like

    No bubbles in my coral life skimmer.

    Ok guys I have tried everything. Im sure that the problem is so small that I have passed it up. I added a pump to a used coral life skimmer 125. Tried to put it in the new tank and everything works fine. The only problem is that I have very few bubbles. Almost none. When I blow into the air line I have bubbles but it stops immediately. Throw me some advice.
    The pump is in less than 5 inches of water and the airline is brand new.



    For the clowns.

    NO I will not blow into my skimmer forever.
    NO I will not pay someone to blow into my skimmer.
    NO I Wil not force my child to blow into the skimmer.

    Sent from my SPH-L710 using Tapatalk

  2. #2
    Registered User Levi's Avatar

    Join Date
    Nov 2012
    Location
    Lima, OH
    Posts
    7,957
    Post Thanks / Like
    Salt creep in venturi valve? I had a coralife and hated it, had to add an airpump and wood airstone inside a piece of PVC attached to the inlet of the water pump so it sucked in super fine bubbles. Is it a needle wheel pump?

    Sent from my LG-D801 using Tapatalk

  3. #3
    Public Relations Liasion

    static reef's Avatar

    Join Date
    Nov 2012
    Location
    colorado
    Posts
    3,793
    Post Thanks / Like
    Yeah its a needle wheel. I did a bunch of reading and most people seem to really enjoy them. I just can't get it started.

    Sent from my SPH-L710 using Tapatalk

  4. #4
    Registered User Levi's Avatar

    Join Date
    Nov 2012
    Location
    Lima, OH
    Posts
    7,957
    Post Thanks / Like
    Yeah mine would just quit randomly so I added the wooden airstone

    Sent from my LG-D801 using Tapatalk

  5. #5
    Senior Member charleshardy5's Avatar

    Join Date
    Nov 2013
    Posts
    2,672
    Post Thanks / Like
    Quote Originally Posted by static reef View Post
    Ok guys I have tried everything. Im sure that the problem is so small that I have passed it up. I added a pump to a used coral life skimmer 125. Tried to put it in the new tank and everything works fine. The only problem is that I have very few bubbles. Almost none. When I blow into the air line I have bubbles but it stops immediately. Throw me some advice.
    The pump is in less than 5 inches of water and the airline is brand new.



    For the clowns.

    NO I will not blow into my skimmer forever.
    NO I will not pay someone to blow into my skimmer.
    NO I Wil not force my child to blow into the skimmer.

    Sent from my SPH-L710 using Tapatalk
    Lol way to cut the jokesters off at the pass.

    Sent from my SPH-L710 using Tapatalk
    Last time I checked my watch this was America!

  6. #6
    SCMAS President

    hooked's Avatar

    Join Date
    Jan 2009
    Location
    Colorado Springs, CO.
    Posts
    7,212
    Post Thanks / Like
    Quote Originally Posted by Levi View Post
    Salt creep in venturi valve? I had a coralife and hated it, had to add an airpump and wood airstone inside a piece of PVC attached to the inlet of the water pump so it sucked in super fine bubbles. Is it a needle wheel pump?

    Sent from my LG-D801 using Tapatalk
    +1. These skimmers worked well enough. Buy you have to watch them. When I had mine, I would have to clean the cup out every couple of days. I always had to chase out the venturi with a small drill bit. They build up with salt quickly. I Bypassed the muffler completely. It was plugged and cut off any air flow.
    Doyle

    "It's better to be silent and thought the fool than to open your mouth and remove all doubt."



    90g sps Reef, DIY LED Lighting.
    180g Reef - rebirth started Jan 2013
    260g Coral Propagation System.


    Go dtí go bhfilleann sé abhaile!

  7. #7
    Senior Member
    Sharkboy99999's Avatar

    Join Date
    Mar 2014
    Posts
    1,378
    Post Thanks / Like
    I have no problems with mine . For now atlest


    Sent from my iPhone using Tapatalk

  8. #8
    Public Relations Liasion

    static reef's Avatar

    Join Date
    Nov 2012
    Location
    colorado
    Posts
    3,793
    Post Thanks / Like
    I figured it out. The venturi has to be on the suction side of the pump not the output side. Second trip to big r today for a few misc plumbing parts and bam! I got bubbles.

    Sent from my SPH-L710 using Tapatalk

  9. #9
    SCMAS President

    hooked's Avatar

    Join Date
    Jan 2009
    Location
    Colorado Springs, CO.
    Posts
    7,212
    Post Thanks / Like
    Good catch. Would have not caught that through discussion only.
    Doyle

    "It's better to be silent and thought the fool than to open your mouth and remove all doubt."



    90g sps Reef, DIY LED Lighting.
    180g Reef - rebirth started Jan 2013
    260g Coral Propagation System.


    Go dtí go bhfilleann sé abhaile!

  10. #10
    Public Relations Liasion

    static reef's Avatar

    Join Date
    Nov 2012
    Location
    colorado
    Posts
    3,793
    Post Thanks / Like
    Everyone kept talking about the venturi. I have had skimmers that it didnt matter. I guess this specific pump isnt designed that way. The pump itselp will have to be changed out. Its pretty loud. I also covered the output line with a 6"x4" block of filter floss. 0 minutes rock bubbles now.

    Sent from my SPH-L710 using Tapatalk

  11. #11
    Registered User chriscreasman's Avatar

    Join Date
    Jan 2013
    Location
    Falcon, CO
    Posts
    136
    Post Thanks / Like
    Is it one of those Italian pumps? Some times when you plug them in the run backwards. Unplug and try again.....

  12. #12
    Public Relations Liasion

    static reef's Avatar

    Join Date
    Nov 2012
    Location
    colorado
    Posts
    3,793
    Post Thanks / Like
    Quote Originally Posted by chriscreasman View Post
    Is it one of those Italian pumps? Some times when you plug them in the run backwards. Unplug and try again.....
    Duh. Tried that already. Lol

    Sent from my SPH-L710 using Tapatalk

  13. #13
    Registered User chriscreasman's Avatar

    Join Date
    Jan 2013
    Location
    Falcon, CO
    Posts
    136
    Post Thanks / Like
    I figured as much but some times the most simple thing is forgotten about. When I was an electrician and stuff didn't work after I tried to fix it, it was usually not working because it wasn't plugged in. LOL

  14. #14
    SCMAS President

    hooked's Avatar

    Join Date
    Jan 2009
    Location
    Colorado Springs, CO.
    Posts
    7,212
    Post Thanks / Like
    Quote Originally Posted by chriscreasman View Post
    I figured as much but some times the most simple thing is forgotten about. When I was an electrician and stuff didn't work after I tried to fix it, it was usually not working because it wasn't plugged in. LOL
    Done that before. I even bought new brushes for my DA sander. Put them in and it still didn't work. Then my wife plugged it in for me. AMAZING!!!
    Doyle

    "It's better to be silent and thought the fool than to open your mouth and remove all doubt."



    90g sps Reef, DIY LED Lighting.
    180g Reef - rebirth started Jan 2013
    260g Coral Propagation System.


    Go dtí go bhfilleann sé abhaile!

  15. #15
    Public Relations Liasion

    static reef's Avatar

    Join Date
    Nov 2012
    Location
    colorado
    Posts
    3,793
    Post Thanks / Like
    You go girl

    Sent from my SPH-L710 using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •