PDA

View Full Version : Hi everyone



Hydroid
09-02-2013, 09:04 AM
Im new to reef keeping and new to the forum

Been in the hobby about 6 months

Looking forward to learning and making a few friends

Here's my tank info I bought/rescued this tank about 6 months ago it was very neglected. everything has been going great except for an embarrassing hair algae battle. :icon_redface:


55 gallon tank with 20 gal sump over sized skimmer (dont know brand) and matrix biomedia
2 - 50/50 21" compact florescent (saving for led)

1 clown fish
Hawaiian feather duster
Very large red and white brittle star
2 peppermint shrimp
A coral banded shrimp
Long tentacled purple anemone (not sure what kind)
Small red Sea star Lanka i think
Emerald crab
Basic CUC of red hermit crabs and various snails
2 large nassarius snails
1 conch

1 head golden torch coral
2 head green torch coral
Small frag of frogspawn
Various buttons and zoas
2 branches of candy cane coral
Small colony Star plops
One purple-ish ricordea
Numerous red mushrooms
2 large 1 small toadstools
And a couple I don't know

Murfman
09-02-2013, 09:09 AM
Welcome. With the livestock you have in there, see about raising your magnesium level to 1650 or higher. Raise it slowly and watch the hair algae go away. Plenty of threads about what peeps have done to get rid of it, here.

Hydroid
09-02-2013, 09:24 AM
Thank you for the advise. i haven't been testing for mag. what a noob huh so much to learn.

Murfman
09-02-2013, 09:35 AM
If you can take any of the rock out, using a syringe of hydrogen peroxide will get rid of it in one treatment. I wouldn't dose with those inverts in the tank though.

89delta
09-02-2013, 11:06 AM
+1 to what murfman said. I had the same issue as well and used his recommended dosing treatments for my cyno and hair algae outbreak.

Sent from my SAMSUNG-SGH-I717 using Tapatalk 4

Larrypueblo
09-02-2013, 07:31 PM
welcome

static reef
09-03-2013, 09:13 AM
Welcome.

Sent from my SPH-L710 using Tapatalk 2